Support for MS Office 2016 added

2016-02-10 10:06

The world is turning - so we added support for MS Office 2016. Now we support all version since Office 2010. Actual we support all versions since Office 2000 but our OutLook Add in needs MS Office 2010 or higher.

Go back